In order to meet the latest PCI Data Security Standards (PCI DSS) we will be dropping support for TLS 1.0 and the TLS_RSA_WITH_3DES_EDE_CBC_SHA ciphers on all servers in our infrastructure.

The deadline set from the PCI Security Standards Council is the 30th of June, 2018. You can read more about it here.

After this update, customers using legacy browsers and user agents will be unable to access any SSL secured website hosted in our platform.

These user agents include but not limited to:

  1. any browser running on Windows XP
  2. any browser running on Android 4.4 or earlier
  3. Internet Explorer 10 and below
  4. Firefox 23 and below
  5. Chrome 21 and below
  6. any clients using Java 1.7 or earlier
  7. curl and wget command line clients using OpenSSL versions priors to v1.0.1

If your browser and operating system is up to date, then you should probably be OK.

If you are unsure whether this change will affect you or not you can visit this test page.

If you have any questions regarding this security change, please raise a ticket and our support team will gladly answer your questions.